import re
regex = re.compile(r"(?:youtube\.com\/\S*(?:(?:\/e(?:mbed))?\/|watch\?(?:\S*?&?v\=))|youtu\.be\/)([a-zA-Z0-9_-]{6,11})")
test_str = ("Regular expressions can be a pain. This tool is designed to help developers learn, practice, and compose regular expressions.\n\n"
"## tests:\n\n"
"// should not match\n"
"youtube.com/embed/v=0EWbonj7f18\n"
"youtube.com/e/v=0EWbonj7f18\n"
"youtube.com/attribution_link?u=/embed/v=0EWbonj7f18\n"
"youtube.com/attribution_link?u=/e/v=0EWbonj7f18\n"
"hey guys go to youtube and v=thisweird video i found\n"
"i found a youtube video on 4chan /v/foobarbaz\n"
"but we work at youtu.be and /thisweird video\n\n"
"// short links\n"
"youtu.be/WijF8aivOo8\n"
"youtu.be/0EWbonj7f18\n\n"
"// mixed\n"
"youtube.com/user/sandervandoorntv/watch?v=WijF8aivOo8\n"
"youtube.com/user/sandervandoorntv/watch?v=WijF8aivOo8&feature=related\n"
"youtube.com/user/sandervandoorntv/watch?feature=related&v=WijF8aivOo8\n"
"youtube.com/watch?v=0EWbonj7f18\n"
"youtube.com/watch?feature=related&v=0EWbonj7f18\n"
"youtube.com/watch?v=0EWbonj7f18&feature=related\n"
"youtube.com/embed/watch?v=0EWbonj7f18\n"
"youtube.com/embed/watch?feature=related&v=0EWbonj7f18\n"
"youtube.com/embed/v/0EWbonj7f18\n"
"youtube.com/e/v/0EWbonj7f18\n"
"youtube.com/e/watch?v=0EWbonj7f18\n"
"youtube.com/e/watch?feature=related&v=0EWbonj7f18\n\n"
"// attribution link\n"
"youtube.com/attribution_link?u=/user/sandervandoorntv/watch?v=WijF8aivOo8\n"
"youtube.com/attribution_link?u=/user/sandervandoorntv/watch?v=WijF8aivOo8&feature=related\n"
"youtube.com/attribution_link?u=/user/sandervandoorntv/watch?feature=related&v=WijF8aivOo8\n"
"youtube.com/attribution_link?u=/watch?v=0EWbonj7f18\n"
"youtube.com/attribution_link?u=/watch?feature=related&v=0EWbonj7f18\n"
"youtube.com/attribution_link?u=/watch?v=0EWbonj7f18&feature=related\n"
"youtube.com/attribution_link?u=/embed/watch?v=0EWbonj7f18\n"
"youtube.com/attribution_link?u=/embed/watch?feature=related&v=0EWbonj7f18\n"
"youtube.com/attribution_link?u=/embed/v/0EWbonj7f18\n"
"youtube.com/attribution_link?u=/e/v/0EWbonj7f18\n"
"youtube.com/attribution_link?u=/e/watch?v=0EWbonj7f18\n"
"youtube.com/attribution_link?u=/e/watch?feature=related&v=0EWbonj7f18\n\n"
"The HiFi RegExp tool is 100% JavaScript using jQuery. This tool was created by New Media Campaigns, the team behind HiFi, a next-generation CMS for web designers, developers, and agencies. Enjoy!\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")