use strict;
my $str = '3040.302
$15,405.20
10.10,10.8,-10.9
"ele10.34.5642"
"104fflkd104.35 df10dw4.70"
"$10,000,000.04"';
my $regex = qr/[^0-9.]/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}