package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)([^\s]+)`)
var str = `@JoonasJQWÜPKEQÖW:DQ_D:QWÄ!"_©@©©@¶©”#¶¶©£ l.
on sitaks @tore poiss @kesdfasf haiseb@mail.ee või jaakpeldes @gmail.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}