import re
regex = re.compile(r"^(http(s)?:\/\/)?([\w]+\.)?linkedin\.com\/(pub|in|profile)", flags=re.MULTILINE)
test_str = ("es.linkedin.com/pub/francisco-fernandez/30/14/62\n"
"https://www.linkedin.com/profile/view?id=107523146&authType=name&authToken=A2nj&trk=nmp_pymk_name\n"
"de.linkedin.com/pub/frank-rempp/1/638/7a1\n"
"http://uk.linkedin.com/pub/some-name/1/1b3/b45/\n"
"http://nl.linkedin.com/pub/other-name/11/223/544\n"
"http://www.linkedin.com/in/aname/\n"
"http://www.linkedin.com/in/another-name\n"
"http://linkedin.com/in/name\n"
"http://nl.linkedin.com/in/name\n"
"http://nl.linkedin.com/in/name/")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)