$re = '/(?s)^.*?(\b[A-Z]{3,}\s+\d{2}-\d{2})(?!-).*/';
$str = 'foo bar MAY 01-15 Lorem ipsum dolor sit amet, consetetur, adipisci velit';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);