re = /(?s)^.*?(\b[A-Z]{3,}\s+\d{2}-\d{2})(?!-).*/
str = 'foo bar MAY 01-15 Lorem ipsum dolor sit amet, consetetur, adipisci velit'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end