re = /-----BEGIN PUBLIC KEY-----(.*)-----END PUBLIC KEY-----/
str = 'KEY_ID: 1
STATUS: VALID
-----BEGIN PUBLIC KEY-----
MFkwEwYHKoZIzj0CAQYIKoZIzj0DAQcDQgAEaq6djyzkpHdX7kt8DsSt6IuSoXjp
WVlLfnZPoLaGKc/2BSfYQuFIO2hfgueQINJN3ZdujYXfUJ7Who+XkcJqHQ==
-----END PUBLIC KEY-----'
# Print the match result
str.match(re) do |match|
puts match.to_s
end