package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)xxx\s([0-9]+\s){3}xxx`)
var str = `xxx 123 456 789 xxx`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}