$re = '/xxx\s([0-9]+\s){3}xxx/m';
$str = 'xxx 123 456 789 xxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);