# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(href|src)="((\\/\\/)(.+))"/$1="https:\/\/$4"/gmU;t' <<< "<a href=\"//commons.wikimedia.org/wiki/File:Guido_van_Rossum_OSCON_2006.jpg?uselang=ru\" class=\"image\">
<img alt=\"\" src=\"//upload.wikimedia.org/wikipedia/commons/thumb/6/66/Guido_van_Rossum_OSCON_2006.jpg/220px-Guido_van_Rossum_OSCON_2006.jpg\" decoding=\"async\" width=\"220\" height=\"330\" class=\"thumbimage\" srcset=\"//upload.wikimedia.org/wikipedia/commons/thumb/6/66/Guido_van_Rossum_OSCON_2006.jpg/330px-Guido_van_Rossum_OSCON_2006.jpg 1.5x, //upload.wikimedia.org/wikipedia/commons/thumb/6/66/Guido_van_Rossum_OSCON_2006.jpg/440px-Guido_van_Rossum_OSCON_2006.jpg 2x\" data-file-width=\"2336\" data-file-height=\"3504\">
</a>"