import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^header\\d+[\\s\\S]+?(?=^header|\\Z))";
final String string = "# output could containmultiple headers, and lines, or no lines per header this is an example of what could be present but it is not absolute. \n\n"
+ "header1\n"
+ "-------\n"
+ "line1\n"
+ "line2\n"
+ "line3 # can be muiplies availables or known\n\n"
+ "header2\n"
+ "-------\n"
+ "line1\n"
+ "line2\n"
+ "line3 # can be muiplies availables or known\n\n"
+ "header3\n"
+ "-------\n\n"
+ "header4\n"
+ "-------\n"
+ "line1\n"
+ "line2\n"
+ "line3 # can be multiple linnes or none not known ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}