import re
regex = re.compile(r"(^header\d+[\s\S]+?(?=^header|\Z))", flags=re.MULTILINE)
test_str = ("# output could containmultiple headers, and lines, or no lines per header this is an example of what could be present but it is not absolute. \n\n"
"header1\n"
"-------\n"
"line1\n"
"line2\n"
"line3 # can be muiplies availables or known\n\n"
"header2\n"
"-------\n"
"line1\n"
"line2\n"
"line3 # can be muiplies availables or known\n\n"
"header3\n"
"-------\n\n"
"header4\n"
"-------\n"
"line1\n"
"line2\n"
"line3 # can be multiple linnes or none not known ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")