$re = '/^([A-Z][a-z]+ )*[A-Z][a-z]+/m';
$str = 'Sao Jose Do Rio Preto 1
Sao Jose Do Rio Preto 2
San Luis 1
Belo Horizonte 3
Rio De Janeiro EDU
Goiania (Jc-01)
Rio De Janeiro (JE-09)
Rio De Janeiro 1 (CFMG)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);