import Foundation
let pattern = #"^([A-Z][a-z]+ )*[A-Z][a-z]+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Sao Jose Do Rio Preto 1
Sao Jose Do Rio Preto 2
San Luis 1
Belo Horizonte 3
Rio De Janeiro EDU
Goiania (Jc-01)
Rio De Janeiro (JE-09)
Rio De Janeiro 1 (CFMG)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)