$re = '/^(?!locales\/US).*/m';
$str = 'locales/DE/en
locales/FR/en
locales/US/en
locales/US/fr
public
test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);