re = /^(?!locales\/US).*/m
str = 'locales/DE/en
locales/FR/en
locales/US/en
locales/US/fr
public
test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end