use strict;
my $str = 'node_modules/example/
node_modules/something/
node_modules/somethingone/
node_modules/somethingelse
node_modules/locales/US/fr
node_modules/public
node_modules/test';
my $regex = qr/^node_modules\/(?!example).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}