$re = '/^node_modules\/(?!example).*/m';
$str = 'node_modules/example/
node_modules/something/
node_modules/somethingone/
node_modules/somethingelse
node_modules/locales/US/fr
node_modules/public
node_modules/test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);