$re = '/\s*:engine\s*\=\>\s*[\'"](\w+)[\'"]/m';
$str = 'source \'https://rubygems.org\'
ruby \'RUBY_VERSION\', :engine => \'ENGINE\', :engine_version => \'ENGINE_VERSION\'
ruby "1.9.3"
ruby "1.8.7", :engine => "jruby", :engine_version => "1.6.7"
ruby \'1.9.3\', :engine => \'jruby\', :engine_version => \'1.6.7\'
ruby 1.9.3 (jruby 1.6.7)
ruby "1.9.3", :engine => "jruby", :engine_version => "1.7.8"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);