// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\s*:engine\s*\=\>\s*['"](\w+)['"]"#).unwrap();
let string = "source 'https://rubygems.org'
ruby 'RUBY_VERSION', :engine => 'ENGINE', :engine_version => 'ENGINE_VERSION'
ruby \"1.9.3\"
ruby \"1.8.7\", :engine => \"jruby\", :engine_version => \"1.6.7\"
ruby '1.9.3', :engine => 'jruby', :engine_version => '1.6.7'
ruby 1.9.3 (jruby 1.6.7)
ruby \"1.9.3\", :engine => \"jruby\", :engine_version => \"1.7.8\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}