package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$(.*)`)
var str = `3469$cosmeticsview@.png,3470SQL.txt`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}