$re = '/\$(.*)/';
$str = '3469$cosmeticsview@.png,3470SQL.txt';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);