$re = '/^(?::?%[nmp])+$/m';
$str = '%n%m%p
%n:%m%p
%n3%p%m
%nm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);