using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/?\*[a-z|A-Z|0-9|\s]+\*?\/";
string input = @"/*
Commentaire 45
*/
Another
//";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}