$re = '/\/?\*[a-z|A-Z|0-9|\s]+\*?\//';
$str = '/*
Commentaire 45
*/
Another
//';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);