use strict;
my $str = '  some tring   with sapce    nm  more space 5 now     end.    .';
my $regex = qr/\s{2,}/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";