re = /\s{2,}/m
str = ' some tring with sapce nm more space 5 now end. .'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result