using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(0[1-9]|1\d|2[1-8]|29(?=-\d\d-(?!1[26]00|2[048]00)\d\d(?:[02468][048]|[13579][26]))|30(?!-02)|31(?=-0[13578]|-1[02]))-(0[1-9]|1[0-2])-[12]\d{3} ([01]\d|2[0-3]):([0-5]\d):([0-5]\d)$";
string input = @"29-02-1600 15:11:45
29-02-1604 23:59:59
29-02-2001 15:11:45
31-01-2000 00:00:00
30-02-2000 15:11:45
29-02-2004 15:11:45
31-02-2000 15:11:45
31-12-2000 15:11:45
31-06-2000 15:11:45
15-02-2000 15:11:45
29-02-2002 15:11:45
02-02-2000 15:11:45
29-02-2000 15:11:45
28-02-2000 15:11:45";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}