import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0[1-9]|1\\d|2[1-8]|29(?=-\\d\\d-(?!1[26]00|2[048]00)\\d\\d(?:[02468][048]|[13579][26]))|30(?!-02)|31(?=-0[13578]|-1[02]))-(0[1-9]|1[0-2])-[12]\\d{3} ([01]\\d|2[0-3]):([0-5]\\d):([0-5]\\d)$";
final String string = "29-02-1600 15:11:45\n"
+ "29-02-1604 23:59:59\n"
+ "29-02-2001 15:11:45\n"
+ "31-01-2000 00:00:00\n"
+ "30-02-2000 15:11:45\n"
+ "29-02-2004 15:11:45\n"
+ "31-02-2000 15:11:45\n"
+ "31-12-2000 15:11:45\n"
+ "31-06-2000 15:11:45\n"
+ "15-02-2000 15:11:45\n"
+ "29-02-2002 15:11:45\n"
+ "02-02-2000 15:11:45\n"
+ "29-02-2000 15:11:45\n"
+ "28-02-2000 15:11:45";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}