package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^i=\d+(?:&s\d+=\d+)+$`)
var str = `i=1&s1=122&s2=238&s3=167&s4=756&s5=13`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}