import Foundation
let pattern = #"\${([\w.]+)*(?::([\w]+))?}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
this is a ${partId} in a sentence
this is a ${param.someId} in a sentence
this is a ${partId:number} in a sentence
this is a ${userId:string} in a sentence
this is a ${param.someFlag:boolean} in a sentence
a ${lotId} and a ${panelId} in a sentence
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)