package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\w-]+`)
var str = `1323 99BIMCP 1 2 BMWQ-CSPS-D1, 0192, '29229'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}