$re = '/[\w-]+/m';
$str = '1323 99BIMCP 1 2 BMWQ-CSPS-D1, 0192, \'29229\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);