#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:^.{48}|\.)([0-9]+\.?)"
Local $sString = "39 9" & @CRLF & _
"30 30 30 31 34 30 30 32 33 32 36 30 31 38 0D 0A 00014002326018.." & @CRLF & _
"39 30 30 30 31 34 30 30 32 33 32 36 30 35 34 0D 900014002326054." & @CRLF & _
"0A ." & @CRLF & _
"39 30 30 30 31 34 30 30 32 33 32 36 30 39 31 0D 900014002326091." & @CRLF & _
"0A ." & @CRLF & _
"39 30 30 30 31 34 30 30 32 33 32 36 31 36 33 0D 900014002326163." & @CRLF & _
"0A ." & @CRLF & _
"39 9" & @CRLF & _
"30 30 30 31 34 30 30 32 33 000140023" & @CRLF & _
"32 36 32 30 30 0D 0A 26200.." & @CRLF & _
"39 9" & @CRLF & _
"30 30 30 31 34 30 30 32 33 32 36 32 30 30 0D 0A 00014002326200.." & @CRLF & _
"39 30 30 30 31 34 30 30 32 33 32 36 31 32 32 0D 900014002326122." & @CRLF & _
"0A ." & @CRLF & _
"39 9" & @CRLF & _
"30 30 30 31 34 30 30 32 33 000140023" & @CRLF & _
"32 36 31 35 34 0D 0A 26154.." & @CRLF & _
"39 30 30 30 31 34 30 30 32 33 9000140023" & @CRLF & _
"32 36 31 33 31 0D 0A 26131.." & @CRLF & _
"39 9" & @CRLF & _
"30 30 30 31 34 30 30 32 33 000140023" & @CRLF & _
"32 36 31 30 34 0D 0A 26104.." & @CRLF & _
"39 30 30 30 31 34 30 30 32 33 32 36 30 39 30 0D 900014002326090." & @CRLF & _
"0A ." & @CRLF & _
"39 30 30 30 31 34 30 30 32 33 32 36 31 39 37 0D 900014002326197." & @CRLF & _
"0A ." & @CRLF & _
"39 9" & @CRLF & _
"30 30 30 31 34 30 30 32 33 32 36 32 30 38 0D 0A 00014002326208.." & @CRLF & _
"39 30 30 30 31 34 30 30 32 33 9000140023" & @CRLF & _
"32 36 31 31 35 0D 0A 26115.." & @CRLF & _
"39 9" & @CRLF & _
"30 30 30 31 34 30 30 32 33 000140023" & @CRLF & _
"32 36 31 36 34 0D 0A 26164.." & @CRLF & _
"39 9" & @CRLF & _
"30 30 30 31 34 30 30 32 33 000140023" & @CRLF & _
"32 36 30 31 36 0D 0A 39 30 30 30 31 34 30 30 32 26016..900014002" & @CRLF & _
"33 3" & @CRLF & _
"32 36 32 34 36 0D 0A 26246.." & @CRLF & _
"39 9" & @CRLF & _
"30 30 30 31 34 30 30 32 33 000140023" & @CRLF & _
"32 36 32 34 36 0D 0A 26246.." & @CRLF & _
"39 9" & @CRLF & _
"30 30 30 31 34 30 30 32 33 000140023" & @CRLF & _
"32 36 30 37 39 0D 0A 26079.." & @CRLF & _
"39 9" & @CRLF & _
"30 30 30 31 34 30 30 32 33 000140023" & @CRLF & _
"32 36 31 32 30 0D 0A 26120.." & @CRLF & _
"39 9" & @CRLF & _
"30 30 30 31 34 30 30 32 33 32 36 32 32 38 0D 0A 00014002326228.." & @CRLF & _
"39 30 30 30 31 34 30 30 32 33 9000140023" & @CRLF & _
"32 36 31 38 36 0D 0A 26186.."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")