import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^.{48}|\\.)([0-9]+\\.?)";
final String string = "39 9\n"
+ "30 30 30 31 34 30 30 32 33 32 36 30 31 38 0D 0A 00014002326018..\n"
+ "39 30 30 30 31 34 30 30 32 33 32 36 30 35 34 0D 900014002326054.\n"
+ "0A .\n"
+ "39 30 30 30 31 34 30 30 32 33 32 36 30 39 31 0D 900014002326091.\n"
+ "0A .\n"
+ "39 30 30 30 31 34 30 30 32 33 32 36 31 36 33 0D 900014002326163.\n"
+ "0A .\n"
+ "39 9\n"
+ "30 30 30 31 34 30 30 32 33 000140023\n"
+ "32 36 32 30 30 0D 0A 26200..\n"
+ "39 9\n"
+ "30 30 30 31 34 30 30 32 33 32 36 32 30 30 0D 0A 00014002326200..\n"
+ "39 30 30 30 31 34 30 30 32 33 32 36 31 32 32 0D 900014002326122.\n"
+ "0A .\n"
+ "39 9\n"
+ "30 30 30 31 34 30 30 32 33 000140023\n"
+ "32 36 31 35 34 0D 0A 26154..\n"
+ "39 30 30 30 31 34 30 30 32 33 9000140023\n"
+ "32 36 31 33 31 0D 0A 26131..\n"
+ "39 9\n"
+ "30 30 30 31 34 30 30 32 33 000140023\n"
+ "32 36 31 30 34 0D 0A 26104..\n"
+ "39 30 30 30 31 34 30 30 32 33 32 36 30 39 30 0D 900014002326090.\n"
+ "0A .\n"
+ "39 30 30 30 31 34 30 30 32 33 32 36 31 39 37 0D 900014002326197.\n"
+ "0A .\n"
+ "39 9\n"
+ "30 30 30 31 34 30 30 32 33 32 36 32 30 38 0D 0A 00014002326208..\n"
+ "39 30 30 30 31 34 30 30 32 33 9000140023\n"
+ "32 36 31 31 35 0D 0A 26115..\n"
+ "39 9\n"
+ "30 30 30 31 34 30 30 32 33 000140023\n"
+ "32 36 31 36 34 0D 0A 26164..\n"
+ "39 9\n"
+ "30 30 30 31 34 30 30 32 33 000140023\n"
+ "32 36 30 31 36 0D 0A 39 30 30 30 31 34 30 30 32 26016..900014002\n"
+ "33 3\n"
+ "32 36 32 34 36 0D 0A 26246..\n"
+ "39 9\n"
+ "30 30 30 31 34 30 30 32 33 000140023\n"
+ "32 36 32 34 36 0D 0A 26246..\n"
+ "39 9\n"
+ "30 30 30 31 34 30 30 32 33 000140023\n"
+ "32 36 30 37 39 0D 0A 26079..\n"
+ "39 9\n"
+ "30 30 30 31 34 30 30 32 33 000140023\n"
+ "32 36 31 32 30 0D 0A 26120..\n"
+ "39 9\n"
+ "30 30 30 31 34 30 30 32 33 32 36 32 32 38 0D 0A 00014002326228..\n"
+ "39 30 30 30 31 34 30 30 32 33 9000140023\n"
+ "32 36 31 38 36 0D 0A 26186..";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}