#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\.(?![^()]*\))"
Local $sString = "foo().bar(norf.qux).fubar()"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)