using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(?![^()]*\))";
string substitution = @"";
string input = @"foo().bar(norf.qux).fubar()";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}