package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"[^"\\]*(?:\\.[^"\\]*)*"|\S+`)
var str = `This is "a string" and this is "a \"nested\" string"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}