package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\&([\w-_]*)=([\w\d\.\,-_]*)`)
var str = `devices/VK_GATEWAY/messages/devicebound/%24.to=%2Fdevices%2FVK_GATEWAY%2Fmessages%2FdeviceBound&%24.ct=application%2Fjson&%24.ce=utf-8&p2=3.3&p1=12&p3=4.4&messageId=6c519ec3-6d60-463c-9a47-2159a72d91f9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}