// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\&([\w-_]*)=([\w\d\.\,-_]*)").unwrap();
let string = "devices/VK_GATEWAY/messages/devicebound/%24.to=%2Fdevices%2FVK_GATEWAY%2Fmessages%2FdeviceBound&%24.ct=application%2Fjson&%24.ce=utf-8&p2=3.3&p1=12&p3=4.4&messageId=6c519ec3-6d60-463c-9a47-2159a72d91f9";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}