package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`NAME(.*)(?:FROM|$)`)
var str = `NAME John Nash FROM California
NAME John Nash`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}