$re = '/<(?!\/?(?:t[dr])>).*?>/m';
$str = '<html> </html> <td> </td> <tr> </tr> <body>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);