re = /<(?!\/?(?:t[dr])>).*?>/m
str = '<html> </html> <td> </td> <tr> </tr> <body>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end