$re = '/-\K(?:[^.]*\.){2}[^.]*/';
$str = 'Great.app.ios9.1-com.company.appname.super-ultra.ipa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);