re = /-\K(?:[^.]*\.){2}[^.]*/
str = 'Great.app.ios9.1-com.company.appname.super-ultra.ipa'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end