package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:9\d|1\d{2})(?:\s|-)?years?(?:\s|-)?old`)
var str = `18year old 23 year old 99 years old but not 25-year-old and 91year old cousin is 99 now and 90-year-old or 102 year old`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}