re = /(?:9\d|1\d{2})(?:\s|-)?years?(?:\s|-)?old/m
str = '18year old 23 year old 99 years old but not 25-year-old and 91year old cousin is 99 now and 90-year-old or 102 year old'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end