$re = '/\/?([a-zA-Z0-9_\-+]+)\/?(?:\;[^\/]*)?$/m';
$str = 'edit
/edit
/edit/
/content/edit
/content/edit/
/content/edit;param=foo
/content;param=foo/edit/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);