re = /\/?([a-zA-Z0-9_\-+]+)\/?(?:\;[^\/]*)?$/m
str = 'edit
/edit
/edit/
/content/edit
/content/edit/
/content/edit;param=foo
/content;param=foo/edit/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end