using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"..(?=:..$)";
string input = @"00:15:5D:73:48:01";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}